DailyLife72 | Training Cisco | Rouitng Dynamic ( OSPF ) | #Day12 | #Mukti911 | Part3


Assalamu’alaikum Wr. Wb.

A. Pendahuluan
Nah kali ini aku akan share pengalamanku. Pada hari ini masih training Cicso dari BestPath Network, orang dari BestPath Network adalah Mas Fatchurohman dan Mas Rizka Budiman. Hari adalah hari terahkir training Cisco. Dihari terakhir ini adalah pembahasan mengenai Routing Dynamic.
B. Latar Belakang
Diadalaknnya training ini agar dapat mendapatkan ilmu tentang Cisco dan juga dapat kesempatan untuk ikut sertifikasinya.
C. Maksud & Tujuan
Agar dapat memiliki pengalaman dan basic mengenai Cisco dan perangkatnya. Lalu dapat mengimplementasikannya didunia kerja.
D. Waktu Pelaksanaan
  • 08.00 – 12.00 < Training
  • 13.00 – 15.30 < Training
  • 16.00 – 17.30 < Training

E. Hal Yang Disampaikan
Setelah menjelasakan beberapa hal mengenai Routing Dynamic di Cisco. Lalu Aku akan menjelaskan mengenai Routing Dynamic yaitu Routing OSPF.
OSPF apa itu OSPF, Mungkin dari kalian udah banyak yang baca baca artikelku sebelumnya dimana salah satunya membahas tentang Dynamic Routing. Nah pada routing OSPF adalah calah satu contoh ROuting Dynamic. OSPF adalah singkatan dari Open Shortest Path First dimana ia adalah metode routing dynamic yang mampu menjaga, mengatur dan mendistribusikan informasi routing yang perubahanya secara dinamis. Dalam OSPF kalin juga harus mengerti mengenai apa itu Autonomus System yaitu seebuah gabungan dari beberapa jaringan yang sifatnya routing dan memiliki kesamaan metode serta policy pengaturan network, dimana semua dapat dikendalikan oleh Network Administrator.
Fitur ini banyak digunakan untuk memanagement dalam skala jaringan yang sangat besar. Maka dari itu utnutk memudahkan penambahan informasi routing dan meminimalisir kesalahan distribus informasi routing , maka OSPF bisa menjadi sebuah solusi.
OSPF bisa juga dikategorikan sebagai IGP. Apa itu IGP ?.. IGP adalah singkatan dari Interior Gateway Protocol, dimana OSPF memiliki kemampuan Link-State dan Algoritma Djikstra yang jauh lebih efisien dibandingkana protokol IGP yang lainnya. Dalan operasinnya OSPF mengunakan protokolnya sendiri yaitu protokol 89.
Lalu bagaimana cara kerjanya. Cara Kerja OSPF adalah :
Berikut adalah sedikit gambaran mengenai prinsip kerja dari OSPF: 
  • Setiap router membuat Link State Packet (LSP)
  • Kemudian LSP didistribusikan ke semua neighbour menggunakan Link State Advertisement (LSA) type 1 dan menentukan DR dan BDR dalam 1 Area.
  • Masing-masing router menghitung jalur terpendek (Shortest Path) ke semua neighbour berdasarkan cost routing.
  • Jika ada perbedaan atau perubahan tabel routing, router akan mengirimkan LSP  ke DR dan BDR melalui alamat multicast 224.0.0.6
  • LSP akan didistribusikan oleh DR ke router neighbour lain dalam 1 area sehingga semua router neighbour akan melakukan perhitungan ulang jalur terpendek.

Konfigurasi OSPF – Backbone Area
OPSF merupakan protokol routing yang menggunakan konsep hirarki routing, dengan kata lain OSPF mampu membagi-bagi jaringan menjadi beberpa tingkatan. Tingakatan-tingkatan ini diwujudkan dengan menggunakan sistem pengelompokan yaitu area. OSPF memiliki beberapa tipe area diantaranya:
  • Bakcbone – Area 0 (Area ID 0.0.0.0) -> Bertanggung jawab mendistribusikan informasi routing antara non-backbone area. Semua sub-Area HARUS terhubung dengan backbone secara logikal.
  • Standart/Default Area -> Merupakan sub-Area dari Area 0. Area ini menerima LSA intra-area dan inter-area dar ABR yang terhubung dengan area 0 (Backbone area).
  • Stub Area -> Area yang paling “ujung”. Area ini tidak menerima advertise external route (digantikan default area).
  • Not So Stubby Area -> Stub Area yang tidak menerima external route (digantikan default route) dari area lain tetapi masih bisa mendapatkan external route dari router yang masih dalam 1 area.

Lalu bagaimana router yang terkonfigurasi OSPF membentuk Hubungan dengan Router Lain :
Untuk memulai semua aktivitas OSPF dalam menjalankan pertukaran informasi routing, hal pertama yang harus dilakukannya adalah membentuk sebuah komunikasi dengan para router lain. Router lain yang berhubungan langsung atau yang berada di dalam satu jaringan dengan router OSPF tersebut disebut dengan Neighbour Router atau Router Tetangga. Langkah pertama yang harus dilakukan sebuah router OSPF adalah harus membentuk hubungan dengan Neighbor Router.
Router OSPF mempunyai sebuah mekanisme untuk dapat menemukan router tetangganya dan dapat membuka hubungan. Mekanisme tersebut disebut dengan istilah Hello protocol. Dalam membentuk hubungan dengan tetangganya, router OSPF akan mengirimkan sebuah paket berukuran kecil secara periodik ke dalam jaringan atau ke sebuah perangkat yang terhubung langsung dengannya. Paket kecil tersebut dinamai dengan istilah Hello packet.
Pada kondisi standar, Hello packet dikirimkan berkala setiap 10 detik sekali (dalam media broadcast multiaccess) dan 30 detik sekali dalam media Point-to-Point. Hello packet berisikan informasi seputar pernak-pernik yang ada pada router pengirim. Hello packet pada umumnya dikirim dengan menggunakan multicast address untuk menuju ke semua router yang menjalankan OSPF (IP multicast 224.0.0.5). Semua router yang menjalankan OSPF pasti akan mendengarkan protocol hello ini dan juga akan mengirimkan hello packet-nya secara berkala. Cara kerja dari Hello protocol dan pembentukan neighbour router terdiri dari beberapa jenis, tergantung dari jenis media di mana router OSPF berjalan.
OSPF memiliki 3 tabel di dalam router :
  • Routing table biasa juga disebut sebagai Forwarding database. Database ini berisi the lowest cost untuk mencapai router-router/network-network lainnya. Setiap router mempunyai Routing table yang berbeda-beda.
  • Adjecency database, Database ini berisi semua router tetangganya. Setiap router mempunyai Adjecency database yang berbeda-beda.
  • Topological database, Database ini berisi seluruh informasi tentang router yang berada dalam satu networknya/areanya.

Kelebihan da
ri OSPF sebagai berikut
  • Tidak menghasilkan routing loop
  • Mendukung penggunaan beberapa metrik sekaligus
  • Dapat menghasilkan banyak jalur ke sebuah tujuan
  • Membagi jaringan yang besar mejadi beberapa area.
  • Waktu yang diperlukan untuk konvergen lebih cepat

Kekurangan dari OSPF sebagai berikut :
  • Membutuhkan basis data yang besar
  • Lebih rumit

untuk pembuatan jaringan yang mengunakan router ospf pertama buat dulu sebuah topologi. Nah aku menggunakan topologi seperti gambar diatas. Nah lalu lakukan konfigurasi seperti berikut :

ROUTER R1
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 1.1.1.1 255.255.255.255
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R1
Router(dhcp-config)#network 10.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 10.10.10.1
Router(dhcp-config)#dns-server 10.10.10.1
Router(dhcp-config)#exit
Router(config)#router ospf 11
Router(config-router)#network 10.10.10.0 0.0.0.255 area 0
Router(config-router)#network 20.20.20.0 0.0.0.255 area 0
Router(config-router)#network 1.1.1.1 0.0.0.0 area 0
Router(config-router)#

ROUTER R2Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 20.20.20.20 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 1.1.1.2 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/2
Router(config-if)#ip address 2.2.2.1 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R2
Router(dhcp-config)#network 20.20.20.0 255.255.255.0
Router(dhcp-config)#default-router 20.20.20.1
Router(dhcp-config)#dns-server 20.20.20.1
Router(dhcp-config)#exit
Router(config)#router ospf 11
Router(config-router)#network 10.10.10.0 0.0.0.255 area 0
Router(config-router)#network 20.20.20.0 0.0.0.255 area 0
Router(config-router)#network 30.30.30.0 0.0.0.255 area 0
Router(config-router)#network 1.1.1.2 0.0.0.0 area 0
Router(config-router)#network 2.2.2.1 0.0.0.0 area 0
Router(config-router)#

ROUTER R3
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 2.2.2.2 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R3
Router(dhcp-config)#network 30.30.30.0 255.255.255.0
Router(dhcp-config)#default-router 30.30.30.1
Router(dhcp-config)#dns-server 30.30.30.1
Router(dhcp-config)#exit
Router(config)#router rip
Router(config-router)#network 10.10.10.0
Router(config-router)#network 2.2.2.0
Router(config-router)#
Router(config)#router ospf 11
Router(config-router)#network 20.20.20.0 0.0.0.255 area 0
Router(config-router)#network 30.30.30.0 0.0.0.255 area 0
Router(config-router)#network 2.2.2.2 0.0.0.0 area 0
Router(config-router)#

Jika sudah maka hasilnya seperti berikut ini :

Lalu Coba Lakukan test koneksi pada topologi itu :


F. Penutup
Nah itu saja sih yang telah aku lakukan selama seharian ini mungkin beberapa materi yang disampaikan oleh Mas Fatchurohman dan Rizka Budiman. Sekian dari saya terima kasih.

Wassamu’alaikum Wr. Wb. 

by

Tags:

Comments

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *