DAILYLIFE71 | TRAINING CISCO | Routing Dynamic ( RIP) | #DAY12 | #MUKTI911 | Part2


Assalamu’alaikum Wr. Wb.

A. Pendahuluan
Nah kali ini aku akan share pengalamanku. Pada hari ini masih training Cicso dari BestPath Network, orang dari BestPath Network adalah Mas Fatchurohman dan Mas Rizka Budiman. Hari adalah hari terahkir training Cisco. Dihari terakhir ini adalah pembahasan mengenai Routing Dynamic.

B. Latar Belakang
Diadalaknnya training ini agar dapat mendapatkan ilmu tentang Cisco dan juga dapat kesempatan untuk ikut sertifikasinya.

C. Maksud & Tujuan
Agar dapat memiliki pengalaman dan basic mengenai Cisco dan perangkatnya. Lalu dapat mengimplementasikannya didunia kerja.

D. Waktu Pelaksanaan

  • 08.00 – 12.00 < Training
  • 13.00 – 15.30 < Training
  • 16.00 – 17.30 < Training

E. Hal Yang Disampaikan

Setelah menjelasakan beberapa hal mengenai Routing Dynamic di Cisco. Lalu Aku akan menjeaskan mengenai Routing Dynamic yaitu Routing RIP.

Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Oleh karena itu protokol ini diklasifikasikan sebagai Interior Gateway Protocol (IGP). Protokol ini menggunakan algoritme Distance-Vector Routing.

Pertama kali didefinisikan dalam RFC 1058 (1988). Protokol ini telah dikembangkan beberapa kali, sehingga terciptalah RIP Versi 2 (RFC 2453). Kedua versi ini masih digunakan sampai sekarang, meskipun begitu secara teknis mereka telah dianggap usang oleh teknik-teknik yang lebih maju, seperti Open Shortest Path First (OSPF) dan protokol OSI IS-IS.

RIP juga telah diadaptasi untuk digunakan dalam jaringan IPv6, yang dikenal sebagai standar RIPng (RIP Next Generation / RIP generasi berikutnya), yang diterbitkan dalam RFC 2080 (1997).

Versi
Ada tiga versi dari Routing Information Protocol: RIPv1, RIPv2, dan RIPng.

  • RIP versi 1

Spesifikasi asli RIP, didefinisikan dalam RFC 1058, classful menggunakan routing. Update routing periodik tidak membawa informasi subnet, kurang dukungan untuk Variable Length Subnet Mask (VLSM). Keterbatasan ini tidak memungkinkan untuk memiliki subnet berukuran berbeda dalam kelas jaringan yang sama. Dengan kata lain, semua subnet dalam kelas jaringan harus memiliki ukuran yang sama. Juga tidak ada dukungan untuk router otentikasi, membuat RIP rentan terhadap berbagai serangan.

  • RIP versi 2

Karena kekurangan RIP asli spesifikasi, RIP versi 2 (RIPv2) dikembangkan pada tahun 1993 dan standar terakhir pada tahun 1998. Ini termasuk kemampuan untuk membawa informasi subnet, sehingga mendukung Classless Inter-Domain Routing (CIDR). Untuk menjaga kompatibilitas, maka batas hop dari 15 tetap. RIPv2 memiliki fasilitas untuk sepenuhnya beroperasi dengan spesifikasi awal jika semua protokol Harus Nol bidang dalam pesan RIPv1 benar ditentukan. Selain itu, aktifkan kompatibilitas fitur memungkinkan interoperabilitas halus penyesuaian.

Dalam upaya untuk menghindari beban yang tidak perlu host yang tidak berpartisipasi dalam routing, RIPv2 me-multicast seluruh tabel routing ke semua router yang berdekatan di alamat 224.0.0.9, sebagai lawan dari RIP yang menggunakan siaran unicast. Alamat 224.0.0.9 ini berada pada alamat IP versi 4 kelas D (range 224.0.0.0 – 239.255.255.255). Pengalamatan unicast masih diperbolehkan untuk aplikasi khusus. (MD5) otentikasi RIP diperkenalkan pada tahun 1997. RIPv2 adalah Standar Internet STD-56.

  • RIPng

RIPng (RIP Next Generation / RIP generasi berikutnya), yang didefinisikan dalam RFC 2080, adalah perluasan dari RIPv2 untuk mendukung IPv6, generasi Internet Protocol berikutnya. Perbedaan utama antara RIPv2 dan RIPng adalah:
Dukungan dari jaringan IPv6.

  • RIPv2 mendukung otentikasi RIPv1, sedangkan RIPng tidak. IPv6 router itu, pada saat itu, seharusnya menggunakan IP Security (IPsec) untuk otentikasi.
  • RIPv2 memungkinkan pemberian beragam tag untuk rute , sedangkan RIPng tidak;
  • RIPv2 meng-encode hop berikutnya (next-hop) ke setiap entry route, RIPng membutuhkan penyandian (encoding) tertentu dari hop berikutnya untuk satu set entry route .

Batasan

  • Hop count tidak dapat melebihi 15, dalam kasus jika melebihi akan dianggap tidak sah. Hop tak hingga direpresentasikan dengan angka 16.
  • Sebagian besar jaringan RIP datar. Tidak ada konsep wilayah atau batas-batas dalam jaringan RIP.
  • Variabel Length Subnet Masks tidak didukung oleh RIP IPv4 versi 1 (RIPv1).
  • RIP memiliki konvergensi lambat dan menghitung sampai tak terhingga masalah.

Nah Berikut ini adalah beberapa contoh penerapan Routing RIP di Cisco Packet Tracer :

untuk pembuatan jaringan yang mengunakan router rip pertama buat dulu sebuah topologi. Nah aku menggunakan topologi seperti gambar diatas. Nah lalu lakukan konfigurasi seperti berikut :

ROUTER R1
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 1.1.1.1 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R1
Router(dhcp-config)#network 10.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 10.10.10.1
Router(dhcp-config)#dns-server 10.10.10.1
Router(dhcp-config)#exit
Router(config)#router rip
Router(config-router)#network 10.10.10.0
Router(config-router)#network 1.1.1.0
Router(config-router)#

ROUTER R2
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 20.20.20.20 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 1.1.1.2 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/2
Router(config-if)#ip address 2.2.2.1 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R2
Router(dhcp-config)#network 20.20.20.0 255.255.255.0
Router(dhcp-config)#default-router 20.20.20.1
Router(dhcp-config)#dns-server 20.20.20.1
Router(dhcp-config)#exit
Router(config)#router rip
Router(config-router)#network 20.20.20.0
Router(config-router)#network 1.1.1.0
Router(config-router)#network 2.2.2.0
Router(config-router)#

ROUTER R3
Router>enable
Router#configure terminal
Enter configuration
commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface gig0/1
Router(config-if)#ip address 2.2.2.2 255.255.255.248
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip dhcp pool R3
Router(dhcp-config)#network 30.30.30.0 255.255.255.0
Router(dhcp-config)#default-router 30.30.30.1
Router(dhcp-config)#dns-server 30.30.30.1
Router(dhcp-config)#exit
Router(config)#router rip
Router(config-router)#network 10.10.10.0
Router(config-router)#network 2.2.2.0
Router(config-router)#

Jika sudah maka hasilnya seperti berikut ini :

R1

R2

R3

Lalu Coba Lakukan test koneksi pada topologi itu :

F. Penutup

Nah itu saja sih yang telah aku lakukan selama seharian ini mungkin beberapa materi yang disampaikan oleh Mas Fatchurohman dan Rizka Budiman. Sekian dari saya terima kasih.

Wassamu’alaikum Wr. Wb.

by

Tags:

Comments

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *