DAILYLIFE69 | TRAINING CISCO | EherChannel dan DHCP Relay | #DAY10 | #MUKTI911

Assalamu’alaikum Wr. Wb.

A. Pendahuluan

Nah kali ini aku akan share pengalamanku. Pada hari ini masih training Cicso dari BestPath Network, orang dari BestPath Network adalah Mas Fatchurohman dan Mas Rizka Budiman. Hari ini adalah training tentang apa itu dan bagaimana penerapannya Eher Channel dan DHCP Relay di Cisco.

B. Latar Belakang

 Diadalaknnya training ini agar dapat mendapatkan ilmu tentang Cisco dan juga dapat kesempatan untuk ikut sertifikasinya.

C. Maksud & Tujuan

Agar dapat memiliki pengalaman dan basic mengenai Cisco dan perangkatnya. Lalu dapat mengimplementasikannya didunia kerja.

D. Waktu Pelaksanaan

  • 08.00 – 12.00 < Training
  • 13.00 – 15.30 < Training
  • 16.00 – 17.30 < Training
  • 19.30 – 22.00 < Training

E. Hal Yang Disampaikan


EtherChannel di Cisco

Etherchannel adalah penggabungan beberapa link pada switch menjadi satu link secara virtual. Tujuannua adalah untuk menggabungkan bandwidth yang tersedia dan juga untuk menyediakan ukuran physical redundancy. Dengan etherchannel, beberapa link digroup ke dalam sebuah port-channel yang dapat dikonfigurasi pada interface virtualnya sesuai kebutuhan.

  • EtherChannel Negotiation, Sebuah etherchannel dapat dibangun dengan menggunakan satu dari tiga mekanisme berikut :
    • PAgP : cisco’s proprietary
    • LACP : open standard IEEE 802.3ad 
    • Static Persistence (“on”) : No negotiation

Salah satu dari tiga mekanisme di atas akan cukup untuk sebagian besar skenario, namun perlu beberapa pertimbangan untuk pemilihannya. LACP membantu melakukan proteksi switching loop yang disebabkan oleh miskonfigurasi, ketika di enable, etherchannel hanya akan terbentuk setelah negosiasi antara kedua switch berhasil. Namun, negosiasi ini akan menyebabkan terjadi delay.

Untuk mengkonfigurasi etherchannel menggunakan LACP, setiap sisi harus di set mode active atau passive. Interface yang dikonfigurasi mode active akan memulai negosiasi etherchannel. Interface mode passive akan merespon LACP request dari interface active. Pada dasarnya hal ini akan sama pada PAgP, namun mode yang digunakan pada PAgP adalah mode desirable yang melakukan negosiasi etherchannel dan mode auto yang melakukan respon terhadap request PAgP.

Konfigurasi Etherchannel :

S1(config)#interface range f0/13 -15
S1(config-if-range)#channel-group 1 mode ?
  active      Enable LACP unconditionally
  auto        Enable PAgP only if a PAgP device is detected
  desirable Enable PAgP unconditionally
  on          Enable Etherchannel only
  passive   Enable LACP only if a LACP device is detected
S1(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1

Sebagai catatan, interface port-channel adalah interface virtual yang otomatis dicreate saat mengaktifkan etherchannel pada interface. Interface port-channel ini sebagai representative dari link logical dari etherchannel. Untuk verifikasi etherchannel yang telah dibuat, dapat menggunakan perintah show etherchannel summary.

  • EtherChannel Load-Balancing, Pertimbangan lain yang harus diperhatikan ketika mengimplementasikan etherchannel adalah metode dari load-balancing. Etherchannel menawarkan load-balancing hanya per frame bukan per bit. Switch memutuskan frame akan melintas melalui member link yang mana berdasarkan beberapa metode, yaitu:
    • dst-ip, Distribusi load berdasarkan destinasi IP address (layer 3). Paket-paket yang dikirim dengan destinasi IP yang sama akan diforward melalui etherchannel link, namun hanya melalui satu interface fisik (misalkan interface port-channel teridiri dari 2 atau lebih interface fisik). Sedangkan untuk paket-paket dengan destinasi IP yang berbeda akan diforward melalui beberapa interface fisik (lebih dari satu, tergantung jumlah interface fisik yang di bundle dalam interface port-channel).
    • dst-mac, Distribusi load berdasarkan destinasi MAC address (layer 2). Secara prinsip sama dengan dst-ip.
    • dst-port, Distribusi load berdasarkan destinasi port (layer 4 TCP/UDP). Secara prinsip sama dengan dst-mac dan dst-ip. Namun yang jadi pertimbangan adalah destinasi port-nya. Misal paket-paket tujuan port 80 akan melalui salah interface fisik yang sama.
    • src-dst-ip, Distribusi load berdasarkan source dan destination IP. Apa yang dilakukan metode ini adalah memasangkan source dan destination IP address dan kemudian mengirim paket-paket yang match dengan rule ini melalui salah satu interface fisik pada port-channel. Bedanya dengan dst-ip adalah pada dst-ip paket-paket dengan destinasi IP yang sama akan diforward melalui interface fisik yang sama, tanpa mempertimbagkan source IP nya. Dengan metode src-dst-ip ini, paket-paket dengan destinasi IP yang sama dapat diforward melalui interface fisik yang berbeda jika source IP nya berbeda.
    • src-dst-mac, Distribusi load berdasarkan source dan destinasi MAC address. Prinsipnya sama dengan src-dst-ip.
    • src-dst-port, Distribusi load berdasarkan source dan destinasi port. Prinsipnya sama dengan src-dst-mac.
    • src-ip, Distribusi load berdasarkan source IP address. Paket-paket yang dikirim dengan source IP yang sama walaupun dengan tujuan berbeda akan di forward melalui satu interface fisik dari interface port-channel. Jika source IP berbeda, maka distribusi traffic terbagi ke beberapa interface fisik dari interface port-channel.
    • src-mac, Distribusi load berdasarkan source MAC address. Prinsipnya sama dengan src-ip.
    • src-port, Distribusi load berdasarkan source port. Prinsipnya sama dengan src-ip.
    • dst-mixed-ip-port, Distribusi load berdasarkan destinasi IP address dan destinasi port. 
    • src-mixed-ip-port, Distribusi load berdasarkan source IP addressnya. Prinsipnya sama dst-mixed-ip-port namun kali ini yang dipertimbangkan adalah source-nya.
    • src-dst-mixed-ip-port, Distribusi load berdasarkan gabungan source dan destinasi IP address dan port. Metode ini adalah metode yang terbaik saat ini. Hampir setiap path pada port-channel adalah valid path. Bayangkan saja path yang tidak valid untuk rule ini adalah saat kita memiliki pasangan dari SRC IP : PORT -&
      gt; DST IP: PORT dan telah diforward melalui fa0/2, maka fa0/3 tidak bisa lagi dilalui oleh traffic yang sama. Selain itu, semua traffic dapat di forward melalui beberapa path dengan rule ini. Namun kekurangannya adalah tidak semua IOS support metode ini.
Berikut ini adalah contoh penerapan EtherChannel :
Pertama – tama kita buat topologi seperti berikut
Kemudian kita konfigurasikan Etherchannelnya di semua interface Switch L3 diatas.Untuk modenya kita gunakan mode “on”

MultilayerSwitch0
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int range fa0/1-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#ex
MultilayerSwitch1
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int range fa0/1-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#ex

Setelah itu kita atur IP untuk interface Port-channel nya, setting IP sejaringan antara Switch0 dan Switch1

MultilayerSwitch0
Switch(config)#int port-channel 1
Switch(config-if)#ip address 1.1.1.1 255.255.255.0
MultilayerSwitch1
Switch(config)#int port-channel 1
Switch(config-if)#ip address 1.1.1.2 255.255.255.0

Kemudian cek lampu indikator interface portnya, pastikan sudah berubah menjadi warna hijau. Kemudian coba lakukan ping antar MultilayerSwitch,dan hasilnya berhasil.

DHCP Relay di Cisco

pa yang disebut dengan DHCP relay?, DHCP (untuk Dynamic Host Configuration Protocol)  relay atau agen relay adalah Protokol Bootstrap yang relay DHCP pesan antara klien dan server untuk DHCP pada Jaringan IP yang berbeda. Ini bisa menjadi host atau router IP yang “mendengarkan” pesan klien DHCP disiarkan di subnet dan relai mereka ke server DHCP dikonfigurasi. DHCP server kemudian akan mengirim respon lagi menggunakan agen relay DHCP kembali ke klien DHCP.
Para agen relay DHCP menghemat administrator penderitaan menginstal dan menjalankan setiap server DHCP pada setiap subnet. Sebuah DHCP server atau komputer yang bertindak sebagai server DHCP yang diperlukan untuk setiap segmen jaringan IP yang memiliki klien DHCP. Istilah-istilah ini mungkin terdengar terlalu bertele-tele bagi sebagian orang, sehingga definisi istilah di bawah ini mungkin datang sebagai melegakan. Pada jaringan besar umumnya terdiri dari banyak segmen (umumnya VLAN) dan ratusan atau bahkan ribuan komputer. 
Tentu sulit sekali untuk me-manage IP untuk sekian banyaknya PC itu. Yang mudah tentu menggunakan DHCP Server, namun bagaimana bila segmen dari DHCP Server tersebut berbeda dengan letak PC yang ingin mendapat IP itu? Jawabannya adalah menggunakan DHCP Relay.
Cara kerja DHCP Relay secara sederhana adalah mengarahkan paket DHCP Discover ke DHCP server yang terletak pada segmen yang berbeda, begitu DHCP server memberikan paketDHCP Offer, maka paket ini akan diteruskan oleh Switch ke PC yang bersangkutan dan PC akan membalas dengan paket DHCP request, dimana paket ini akan diteruskan oleh Switch ke DHCP Server, kemudian DHCP Server akan memberikan persetujuan dengan mengirimkan paket DHCP Ack yang akan diteruskan juga oleh Switch ke segmen dimana PC itu berada.

Berikut adalah contoh penerapannya :

Sebegai DHCP Server
Router0 : fa0/0 10.10.10.1/24
                fa0/1 20.20.20.1/30
Sebagai DHCP Relay
Router1 : fa0/0 20.20.20.2/30
                fa0/1 30.30.30.1/25
Server :  10.10.10.254/24
PC19    : DHCP Request
PC20    : DHCP Request

Konfigurasi pada Router2 :

Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#interface fa0/1
Router(config-if)#ip address 20.20.20.1 255.255.255.128
Router(config-if)#no sh
Router(config)#ip route 0.0.0.0 0.0.0.0 20.20.20.2

Konfigurasi DHCP Server pada Router 2 :

Router(config)#ip dhcp pool Mukti911
Router(dhcp-config)#network 30.30.30.0 255.255.255.128
Router(dhcp-config)#default-router 30.30.30.1
Router(dhcp-config)#dns-server 10.10.10.254
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 30.30.30.1

Konfigurasi pada Router3 : 

Router1>enable
Router1#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
Router11(config)#interface fa0/0
Router1(config-if)#ip address 20.20.20.2 255.255.255.128
Router1(config-if)#no sh
Router1(config-if)#exit

Konfigurasi  DHCP Relay pada Router 1 :

R1(config)#interface fa0/1
R1(config-if)#ip help
R1(config-if)#ip helper-address 20.20.20.1
R1(config-if)#exit

Lalu coba lakukan Request pada Client yang ada ditopologi itu jika sudah mendapatkan IP dari Server yaitu ROuter 2 maka konfigurasi berhasil dilakukan.


F. Penutup

Nah itu saja sih yang telah aku lakukan selama seharian ini mungkin beberapa materi yang disampaikan oleh Mas Fatchurohman dan Rizka Budiman. Sekian dari saya terima kasih.
Wassamu’alaikum Wr. Wb.

by

Tags:

Comments

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *