DailyLife63 | Training Cisco | #Day4 | Mukti911


Assalamu’alaikum Wr. Wb.

A. Pendahuluan
Nah kali ini aku akan share pengalamanku. Pada hari ini masih training Cicso dari BestPath Network, orang dari BestPath Network adalah Mas Fatchurohman dan Mas Rizka Budiman. Kali ini membahas Chapter 7 – 9. Lalu menjawab Exam Chapter 1 – 5 di Cisco Academy.

B. Latar Belakang
 Diadakannya training ini agar dapat mendapatkan ilmu tentang Cisco dan juga dapat kesempatan untuk ikut sertifikasinya.

C. Maksud & Tujuan
Agar dapat memiliki pengalaman dan basic mengenai Cisco dan perangkatnya. Lalu dapat mengimplementasikannya didunia kerja.

D. Waktu Pelaksanaan

  • 08.00 – 12.00 < Training
  • 13.00 – 15.30 < Training
  • 16.00 – 17.30 < Training
  • 19.30 – 22.00 < Training

E. Hal Yang Disampaikan

Dalam suatu jaringan yang pasti Security adalah hal yang paling penting dan harus diperhatikan. Setiap hari kalian mungkin tidak mengetahui atau belum menyadari bahwa kalian beresiko terancam keamanannya dengan adanya internet. Lalu metode seperti apa yang dilakukan oleh seseorang yang dapat mengancam keamanan kita saat mengakses jaringan. Lalu langkah seperti apa yang tepat dan harus dilakukan untuk mengurngi resiko adanya ancaman keamanan. Lalu apakah firewall dapat melindungi kita.
Tapi pernahkan kalian berfikir apa yang di butuhkan dan dicari seorang hacker. Sebenarnya ada beberapa hal yang diinginkan oleh seorang Hacker : Information theft, Identity theft, Data loss / manipulation, and Disruption of service. Mereka berasal dari mana? Ancaman eksternal muncul dari individu yang bekerja di luar organisasi. Ancaman internal terjadi bila seseorang memiliki akses yang sah ke jaringan melalui akun pengguna atau memiliki akses fisik ke peralatan jaringan.
Sering kalian lihat atau dengar dari teman teman kalian facebookku dibajak. Social Engineering Dalam konteks keamanan komputer dan jaringan, rekayasa sosial mengacu pada kumpulan teknik yang digunakan untuk menipu pengguna internal agar melakukan tindakan tertentu atau mengungkapkan informasi rahasia. Jenis dari Social Engineering pretexting, phishing, vishing.
Ada juga tipe Hacker dimana dia menanamkan sebuah aplikasi backend dimana dia dapat berkerja sesuai keinginan seorang hacker tersebut. Dalam jenisnya aplikasi ini dapat dibedakan menurut cara mereka menyerang. Software berbahaya dapat merusak sistem, menghancurkan data, serta mengganggu akses jaringan, sistem, atau layanan lainnyaSoftware berbahaya dapat merusak sistem, menghancurkan data, serta mengganggu akses jaringan, sistem, atau layanan lainnya.
Risk
  • Viruses, Program yang menyebar dengan memodifikasi program atau file lain. 
  • Worms,  mirip dengan virus, namun penyebarannya lewat jaringan
  •  Trojan Horse, Merupakan  Aplikasi tiruan yang isinya tool/kode serangan
Dalam serangan Hacker, Hacker memiliki beberapa metode yang digunakannya : 
  • DoS ? Membanjiri sistem atau jaringan dengan lalu lintas untuk mencegah lalu lintas jaringan yang sah agar tidak mengalir (SYN flooding dan ping of death). Mengganggu koneksi antara client dan server untuk mencegah akses ke layanan servernya.
  • Spyware adalah program yang mengumpulkan informasi pribadi dari komputer Anda tanpa seizin atau pengetahuan Anda. Informasi ini dikirim ke pengiklan atau orang lain di Internet dan bisa memasukkan kata sandi dan nomor rekening.
  • Brute Force, Dengan serangan brute force, komputer cepat digunakan untuk mencoba menebak password atau menguraikan kode enkripsi. Penyerang mencoba sejumlah besar kemungkinan dengan cepat untuk mendapatkan akses atau memecahkan kode.
  • Adware adalah bentuk spyware yang digunakan untuk mengumpulkan informasi tentang pengguna berdasarkan situs yang dikunjungi pengguna. Informasi itu kemudian digunakan untuk iklan bertarget.
  • Botnets dan Zombies. Teknik spaming yang bertujuan untuk mengambil data di setiap PC. Zombies = komputer master yang berfungsi mengcontrol semua botnet Botnet = kumpulan komputer yang terinfeksi “bot”.

Lalu bagaimana cara agar dapat menagani atau mengamannkan jaringan. Gunakan Security Tools, Antivirus, dan Firewall.  Caranya bagaimana ya seperti berikut :

  • Security Tools, Banyak alat tersedia bagi pengguna jaringan untuk melindungi perangkat dari serangan dan untuk membantu menghapus perangkat lunak berbahaya dari mesin yang terinfeksi. Security Practices Prosedur keamanan dapat berkisar dari tugas sederhana dan murah seperti mempertahankan rilis software, hingga implementasi firewall dan sistem deteksi yang kompleks. Patches dan Updates, Sebuah patch adalah sepotong kecil kode yang memperbaiki masalah tertentu. Pembaruan, di sisi lain, mungkin mencakup fungsionalitas tambahan pada paket perangkat lunak dan juga tambalan untuk masalah tertentu.
  • Antivirus, Deteksi Infeksi Setiap perangkat yang terhubung ke jaringan rentan terhadap virus, worm dan trojan horse. Jadi bagaimana Anda tahu jika komputer Anda telah terinfeksi Antivirus Software, Antivirus software bergantung pada “tanda tangan virus” yang diketahui untuk menemukan dan mencegah virus baru menginfeksi komputer. Antispam Software Melindungi host dengan mengidentifikasi spam dan melakukan tindakan, seperti menempatkannya ke folder sampah atau menghapusnya. Safeguard, Sebelum meneruskan email peringatan virus, periksa pengirim yang terpercaya untuk mengetahui apakah virus tersebut adalah tipuan. Antispyware, Adware, dan Popup Blockers, Antispyware mendeteksi dan menghapus aplikasi spyware. Banyak aplikasi antispyware juga mencakup deteksi dan penghapusan cookies dan adware. Perangkat lunak pemblokiran popup dapat dipasang untuk mencegah munculan dan pop-under.
  • Firewall mencegah lalu lintas yang tidak diinginkan memasuki kawasan lindung jaringan. Firewall biasanya dipasang di antara dua atau lebih jaringan dan mengendalikan lalu lintas di antara keduanya dan juga membantu mencegah akses yang tidak sah. (permit dan deny)
Selanjutnya adalah mengenal fitur yang ada dalam ROuter & Swicth Cisco. Da
n pula cara mengunakan Cisco IOS. Perintah perintah yang dapat digunakan disana.

Tentu kalian sudah mengenal yang namanya Swicth, switch itu digunakan untuk menghubungkan perangkat-perangkat di jaringan yang sama. Sebuah router itu digunakan untuk mengubungkan beberapa antar jaringan. Saat switch aktif, Power-On-Self-Test (POST) dimulai. Selamat POST, LED berkedip saat serangkaian tes menentukan bahwa switch itu berfungsi dengan baik. POST selesai saat LED SYST berkedip hijau dengan cepat. Jika switch gagal melakukan POST, LED SYST berubah menjadi berwarna kekuningan. Manajemen out-of-band mengharuskan komputer terhubung langsung ke port konsol perangkat jaringan yang sedang dikonfigurasi. Gunakan manajemen in-band untuk memantau dan membuat perubahan konfigurasi ke perangkat jaringan melalui koneksi jaringan.

Sebuah perangkat cisco memuat 2 file berikut ke dalam RAM saat di-boot, IOS Image file, Startup configuration file.

Lalu bagaimana dengan Semua router pada dasarnya adalah komputer. Ya seperti komputer, router memerlukan: sistem operasi (OS), central processing unit (CPU), random access memory (RAM), read-only memory (ROM), dan nonviolative random access memory (NVRAM). Setiap router cisco memiliki komponen perangkat keras umum yang sama, dan koneksi-koneksi ini yaitu: port konsol, 2 interface LAN, dan slot enhanced high-speed WAN interface (EHWIC).
IOS Cisco 
IOS pada Cisco berbasis Teks atau bis adibilang CLI, perintah perintah teks tersebut memungkinkan kita dapat mengkonfigurasi, memantau, memelihara perangkat cisco. Setingan default cisco yaitu blank saat pertama kali konfigurasi gunakan Console. Cisco dalam IOS-nya memisahkan fitur akses management dalam dua mode EXEC user dan mode EXEC Previladged dikarenakan untuk menangani menjaga keamanan tetap ada.

  • Mode User EXEC : Swicth> & Router>
  • Mode User Priviledge EXEC : Swicth# & Router#

Struktur perintah yang ada di IOS bisasanya perintahnya berupa katakunci dan argumennya. Contoh ip add 192.168.16.1 255.255.255.240. Perintah yang tak kalah penting lainnya adalah show untuk memvertivikasi dan mengatasi masalah pengopersian jaringan.

Dalam penerapannya biasanya Switch dan Router dikonfuigurasi sebagai berikut :

  • Ganti nama perangkat.
  • konfigurasi sandi pada mode EXEC user.
  • Jika mengunakan telnet/SSH amankan pula.
  • konfigurasi sandi pada mode EXEC Privilledged.
  • Tambahkan sandi pada seluruh file konfigurasi.
  • Gunakan notifikasi legal
  • Backup konfigurasi.

Setelah itu berikut ini adalah sebuah skenario untuk mengamankan Switch dan Router :

Ini adalah contoh topologi yang telah saya buat ada dua lab yang saling terhubung dengan router.

         — System Configuration Dialog —
Continue with configuration dialog? [yes/no]: n
Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname BLC
BLC(config)#interface GigabitEthernet 0/0
BLC(config-if)#ip address 192.168.10.1 255.255.255.0
BLC(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
BLC(config-if)#exit
BLC(config)#interface gigabitEthernet 0/1
BLC(config-if)#ip add
BLC(config-if)#ip address 192.168.16.1 255.255.255.0
BLC(config-if)#no shutdown
BLC(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
BLC(config-if)#exit
BLC(config)#

BLC(config)#ip domain-name blc-telkom.id
BLC(config)#username blc secret bpn
BLC(config)#enable secret bpn
BLC(config)#crypto key generate rsa
The name for the keys will be: BLC.blc-telkom.id
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]
BLC(config)#line vty 0 4
BLC(config-line)#transport input ssh
BLC(config-line)#login local
BLC(config-line)#exit
BLC(config)# 

BLC(config)#ip dhcp pool BLC
BLC(dhcp-config)#network 192.168.10.0 255.255.255.0
BLC(dhcp-config)#default-router 192.168.10.1
BLC(dhcp-config)#dns-server 8.8.8.8
BLC(dhcp-config)#exit
BLC(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.99
BLC(config)#ip dhcp pool BLC-v2
BLC(dhcp-config)#network 192.168.16.0 255.255.255.0
BLC(dhcp-config)#default-router 192.168.16.1
BLC(dhcp-config)#dns-server 8.8.8.8
BLC(dhcp-config)#exit
BLC(config)#ip dhcp excluded-address 192.168.16.1 192.168.16.99
BLC(config)#
BLC(config)#banner motd “INI ROUTER PENTING JANGAN SALAH KALO UTAK UTIK” 

C:>ssh -l blc 192.168.10.1
Open
Password:
INI ROUTER PENTING JANGAN SALAH KALO UTAK UTIK
BLC>enable
Password:
BLC#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
BLC(config)#

Switch#enable
Switch(config)#hostname Switch99
Switch99(confi
g)#
Switch99#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch99(config)#interface vlan 1
Switch99(config-if)#ip address 192.168.10.10 255.255.255.0
Switch99(config-if)#exit
Switch#enable
Switch(config)#hostname Switch88
Switch88(config)#
Switch88#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch88(config)#interface vlan 1
Switch88(config-if)#ip address 192.168.16.10 255.255.255.0
Switch88(config-if)#exit

F. Penutup
Nah itu saja sih yang telah aku lakukan selama seharian ini mungkin beberapa materi yang disampaikan oleh Mas Fatchurohman dan Rizka Budiman. Sekian dari saya terima kasih.

Wassamu’alaikum Wr. Wb.

by

Tags:

Comments

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *